[リストへもどる]
一括表示
タイトル[K2E] バグでしょうか
記事No3556
投稿日: 2006/06/05(Mon) 17:11
投稿者あさひ
はじめまして。便利に使わせていただいています。

Replace("あ","い","0","0","0","0","4")
このような置換を50個ほど連続して行えるマクロを書いて使っていましたが、先日K2Editor r.1.5.5にアップデートしたところ、置換が成功しているにもかかわらず、
「置換できる文字列はありませんでした」
と表示されメッセージボックスが閉じれなくなりました。PC数台で確認しましたが、どれも同じ結果になりました。
確認していただけると幸いです。

タイトルRe: [K2E] バグでしょうか
記事No3557
投稿日: 2006/06/05(Mon) 19:09
投稿者K2
 K2です。

> Replace("あ","い","0","0","0","0","4")

 をマクロファイルに書いて、「あ」を「い」に置換してみました
が、問題なく動作しました。

 以下質問です。

 うまく動作していたK2Editorのバージョンはいくつでしょうか。
 また、検索対象のファイルの内容と、マクロの全文を教えて
頂けませんか。掲示板にあげるのが問題ありそうでしたら、メール
で、k2 @ k2top. jpn. org(全角スペースをはずしてください)
までお送りください。

 以上、よろしくお願いします。

タイトルRe^2: [K2E] バグでしょうか
記事No3558
投稿日: 2006/06/06(Tue) 19:49
投稿者あさひ
ご返信ありがとうございます。

バージョンアップ前のバージョンはr1.5.5です。
マクロの内容は、
Replace("★","","0","0","0","0","4")
を50個ほど連続して置換させています。
★はwindowsの外字エディタで作った外字で、同じコードを50個でもランダムに50個でも同じ現象になります。また10個に減らしても同じでした。
対象テキストはどんなものでも現象が発生しました。空のファイルや同梱のreadme.txtでもです。
r1.5.5ではひとつずつ置換内容に対して確認の問い合わせがあったのに対し、最新バージョンではすべて置換後に問い合わせがありますが、そのあたりに問題があるように感じました。

いずれにせよまずはk2さんの方で現象を確認していただいてからお話を進めていただきたいと思います。
もし上記の内容で何も出なかった場合、改めてメールにて該当マクロを添付させていただきますので、よろしくお願いします。

タイトルRe^3: [K2E] バグでしょうか
記事No3559
投稿日: 2006/06/07(Wed) 09:43
投稿者K2
 K2です。

 不明点が増えてしまいました(笑)。

 えーと、まずバージョンアップ前のK2Editorバージョンは、
r.1.5.5だということですが、それは最新バージョンです。
うまく動いていたK2Editorのバージョンは何でしょうか。

> マクロの内容は、
> Replace("★","","0","0","0","0","4")
> を50個ほど連続して置換させています。

 マクロには、Replace("★","","0","0","0","0","4")というコマ
ンドが一つだけでしょうか? それは全置換コマンドですので、
50個あっても一気に置換しますので、1行だけ書いてあるのだと
私は推測しましたが、合っていますか?

> ★はwindowsの外字エディタで作った外字で、同じコードを50個でもランダムに50個でも同じ現象になります。また10個に減らしても同じでした。

 外字コードのコードは何でしょうか?

> 対象テキストはどんなものでも現象が発生しました。空のファイルや同梱のreadme.txtでもです。

 同梱のreadme.txtには、お作りになられた外字は入っていない
はずですが、どういうテストを行われたのでしょうか?

> r1.5.5ではひとつずつ置換内容に対して確認の問い合わせがあったのに対し、最新バージョンではすべて置換後に問い合わせがありますが、そのあたりに問題があるように感じました。

 先ほども書きましたが、そのマクロコマンドは全置換オプション
が指定されていますので、一つ一つ問い合わせは行われません。
これはK2Editorの初期バージョンから同じ仕様ですので、
あなたがお書きになられていることがよく理解できません。

 マクロ以外の動作はOKですか? 普通の操作でその外字を置換
することはできますか? その動作は正常でしょうか?
その辺からもう一度調べて頂けないでしょうか。

タイトルRe^4: [K2E] バグでしょうか
記事No3561
投稿日: 2006/06/08(Thu) 08:38
投稿者あさひ
すみません、やはり掲示板では上手く伝わりませんでしたので後日メールにてサポートをお願いいたしますm(__)m